Cisco IOS Router Commands Cheat Sheet

by Remy Pereira on 07th February 2015

Command Modes

ModeSample PromptWhat is Allowed
User EXECRouter1>View Settings
Privilege EXECRouter1#View and change settings
Global ConfigurationRouter1(config)#Change settings for the whole router (global)
Other/Sub ConfigurationRouter1(config-if)#
Router1(config-line)#
Router1(config-subif)#
Router1(config-router)#
....
Change settings specific to interfaces, terminal lines, sub-interfaces, routing etc.,

Navigating from User EXEC to Privilege EXEC

Router1> enable
Router1#

(If password has been set you will be asked for it when you type enable)

Navigating from Privilege EXEC to Global Configuration Mode

Router1# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#

Setting Password for Privilege EXEC (Enable Password)

Router1(config)# enable password abcd1234

(Password is visible in cleartext when running configuration is displayed)

Setting Password with Encryption

Router1(config)# enable secret abcd1234

(Password is encrypted and is not human readable when running configuration is displayed)

Changing hostname

Router1(config)# hostname OTGRouter

Save configuration changes

OTGRouter# copy running-config startup-config

View running configuration

OTGRouter# show running-config

Setting an alias

OTGRouter(config)# alias exec c configure terminal

This sets an alias for the command 'configure terminal' as simply 'c'

Getting help

OTGRouter# ?

This gives general help.

OTGRouter# show ?

This gives the options available for show command.

Configuring an Interface

OTGRouter# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z
OTGRouter(config)# interface FastEthernet0/0
OTGRouter(config-if)# speed 100
OTGRouter(config-if)# duplex full
OTGRouter(config-if)# ip address 172.100.1.1 255.255.255.0
OTGRouter(config-if)# no shutdown

This sets the speed, duplex and IP Address of physical interface FastEthernet0/0. The last command no shutdown makes this interface up and running.

Setting a static route

OTGRouter(config)# ip route 172.200.0.0 255.255.0.0 172.100.1.2

This means 172.100.1.2 is the gateway to the 172.200 sub network

Configuring RIP

OTGRouter(config)# ip routing
OTGRouter(config)# router rip
OTGRouter(config-router)# version 2
OTGRouter(config-router)# no auto-summary
OTGRouter(config-router)# network 172.100.10.0
OTGRouter(config-router)# network 172.100.20.0

The set of commands enable RIP version 2, disable route summarization and declares the directly connected sub networks 172.100.10.0 and 172.100.20.0

Configuring EIGRP

OTGRouter(config)# ip routing
OTGRouter(config)# router eigrp 100
OTGRouter(config-router)# network 172.100.10.0
OTGRouter(config-router)# network 172.100.20.0
OTGRouter(config-router)# no auto-summary

This enables EIGRP with an AS number 100, disables auto summary and declares directly connected sub networks 172.100.10.0 and 172.100.20.0

View Routing Information

OTGRouter# show ip route


Post a comment

Comments

Sanket Utpat | November 13, 2019 11:46 AM |

Useful information thank you but I need more information.

Praven | April 2, 2019 3:45 AM |

This is simple and very helpful

OU | September 15, 2018 9:04 PM |

This has been very useful and helpful. Thank you